“Root database cannot be accessed” Error on Running the Installer

Problem

When running the HotDocs Advance installer, you receive a “The root database cannot be accessed” error message.

Cause

This error is typically caused when the SQL Server user specified in the Advance root database connection string either does not exist or does not have adequate administration privileges.

Solution

  1. Open the json file, located in your unzipped HotDocs Advance folder, in a text editor
  2. Check the user specified in the connection string for the following setting:
    • ConnectionStrings.Root
  3. Open Microsoft SQL Server Management Studio
  4. Check that the user specified in the connection string exists in your SQL Server instance
  5. Check that the user has the dbcreator server role allocated