"Signing Certificate with thumbprint..not found in store" error
Problem
When loading the HotDocsTemplateHubUi application in Internet Explorer or Chrome, you receive a "Signing certificate with thumbprint [thumbprint value] not found in store" error message.
Cause
This error message is typically caused when the Invoke.ps1 script used in the installation process – either with Active Directory or without Active Directory – has not used the correct thumbprint value for your signing certificate. This results in HotDocs Identity Server not locating the certificate.
Solution
You must check the thumbprint of your signing certificate and re-run the invoke.ps1 post-installation script.
1. Check the thumbprint of your signing certificate
- Follow the How to: Retrieve the thumbprint of a certificate instructions to retrieve the thumbprint of your signing certificate.
- Paste the thumbprint into a text editor.
- Delete all spaces from the thumbprint.
- Delete any hidden spaces at the beginning of the thumbprint.
2. Re-run the post-installation script
- Follow the additional script installation instructions for your configuration of Hub; either with Active Directory or without Active Directory
- Copy the thumbprint value from the text editor above.
- Edit the SigningCertificateThumbprint parameter's value in the invoke.ps1 script with the updated thumbprint.
- Run the script.
Try reloading the HotDocsTemplateHubUi application. It should now load without displaying an error.