405 error for Hub service in IIS logs

Problem

When using HotDocs Hub, you receive one of the following errors:

  • Interviews do not load when creating a new work item
  • The Templates page displays an error

There are no error messages in the HotDocsInterviews or other Hub service's log files. When you look in the IIS HTTP logs, you see that a request to a specific Hub application is generating a 405 error message; for example:

2017-01-25 11:05:46 xxx.xx.xxx.xx PUT /HotDocsInterview/api/Sessions/12fv163a-129a-4711-x147-990dccc1ae3 - 443 - xxx.xx.xxx.xx - - 405 0 0 31

Cause

This issue is typically caused when WebDAV is installed and, in one or several Hub applications in IIS, it is not configured to accept all the HTTP verbs that Hub requires.

Solution

It is recommended that your do not have webDAV installed on servers that host HotDocs Hub. However, you can resolve this problem by changing IIS configuration settings for the Hub application to accept all HTTP verbs.

To configure IIS to accept all HTTP verbs

  1. Open Internet Information Services (IIS) Manager.
  2. Navigate to the site under which HotDocs Hub is installed.
  3. Select the Hub application for which a request is causing a 405 error.
  4. Navigate to the Handler Mappings section for the selected application.
  5. Right-click WebDAV in the Handler Mappings list.
  6. Select Edit from the drop-down menu.
  7. Click Request Restrictions.
  8. Navigate to the Verbs tab.
  9. Select the All verbs option.
  10. Click OK.
  11. Click OK.

 

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