Invalid account error when using Active Directory authentication

Problem

When trying to load the HotDocs Hub UI and the Hub is configured to use Active Directory user authentication, you are prompted to use your Windows account to log in to Hub.  

Cause

This issue appears to result from the way Internet Explore and Edge handle cookies on intranet sites. Specifically, this issue occurs if you set Hub to use a single level domain for the site (e.g. https://hotdocs/templatehubui).

Solution

You can resolve this problem by changing the domain to be a multiple level domain (e.g. https://hotdocs.web/templatehubui). This means you must update the IIS settings, the DNS settings, and create an SSL certificate that matches the new multi-level domain, as well as updating and re-running the Invoke.ps1 Powershell script for the relevant settings.

 

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