The Hub UI loads slowly on first use

Problem

When loading or logging into the HotDocsTemplateHubUi application, it takes a long time for the landing page to load.

Cause

This is typically caused by the services required by HotDocs Hub becoming inactive in IIS.

Solution

1. Configure Application Initialization settings in IIS

Application Initialization enables you to configure IIS to proactively perform 'warm up' tasks for a web application, which will reduce its startup time. See Application Initialization for detailed steps on configuring IIS to use Application Initialization.

2. Change the Idle Time-out to 0

  1. Open Internet Information Services (IIS) Manager.
  2. Navigate to Application Pools.
  3. Select the application pool under which the HotDocs Hub applications run.
  4. Click Advanced Settings.
  5. Navigate to the Idle Time-out (minutes) setting.
  6. Change the setting value to 0.
  7. Click OK.

3. Change the Idle Time-out Action to Suspend

  1. Open Internet Information Services (IIS) Manager.
  2. Navigate to Application Pools.
  3. Select the application pool under which the HotDocs Hub applications run.
  4. Click Advanced Settings.
  5. Navigate to the Idle Time-out Action setting.
  6. Select Suspend from the drop-down menu.
  7. Click OK.

 

 

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