HotDocs Hub did not create a database on first load
Problem
The HotDocs Hub databases are not created on first load of a Hub API endpoint. For example, when you load the Templates page in the Hub user interface.
Cause
This is typically caused by the Hub database being installed with the wrong access permissions. For example, if the user that creates the database is not also the user under which the Hub application pool runs.
Solution
1. Configure SQL Server user permissions
The SQL Server user must have appropriate SQL Server permissions to create a database.
2. Load a HotDocs Hub endpoint
HotDocs Hub creates the database when a Hub endpoint loads. For example, when you load the Templates page in the HotDocs Hub user interface.