Active Directory user SID not found when running ConfigureHub script

Problem

When running the ConfigureHub script for a Hub with Active Directory installation, you receive the following message:

Error: Active Directory user SID not found

Please manually update the HotDocsIdentityServer web.config file's AdSid setting with the SID. See help documentation for details.

Cause

This error message is displayed if the ConfigureHub script cannot retrieve the SID (unique identifying number) for the Active Directory user you specified for the AdUser parameter in the ConfigureHub script. You can resolve the issue by manually retrieving the SID and editing the HotDocsIdentityServer application's web.config file to use the SID.

Solution

1. Find the SID of the Active Directory user

  1. Run the Windows Command Prompt as an administrator.
  2. Type the following command:
    wmic useraccount where name='{username}' get sid
    Where username is the Active Directory username for the user you want to use as the Hub root administrator.
  3. Press the Enter key; the SID number for the specified user appears in the command prompt window.

2. Edit the HotDocsIdentityServer application web.config settings

  1. Navigate to the HotDocsIdentityServer installation directory; by default, this is C:\inetpub\wwwroot\HotDocsIdentityServer.
  2. Edit the web.config file.
  3. Edit the following setting in the appSettings section of web.config:
    • ADSid – change value to the SID retrieved above
  4. Save the changes.

 

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