IE and Edge Users Unable to Log in to UI Application

Problem

After installing HotDocs Hub, users are unable to log in to the UI application due to a redirect loop between the UI and Identity Server. The redirect issue only happens with users trying to connect to Hub from an Internet Explorer or Edge browser.

Cause

This issue appears to result from the way Internet Explorer and Edge handle cookies on intranet sites. Specifically, this issue occurs if you set Hub to use a single level domain for the site (e.g. https://hub/HotDocsTemplateHubUi).

Solution

You can resolve this problem by changing the domain to be a multiple level domain (e.g. https://server.yourorganization.com/HotDocsTemplateHubUi). This means you must update the IIS settings, the DNS settings, and create an SSL certificate that matches the new multi-level domain, as well as updating the relevant DefaultConfig.psd1 settings and re-running the ConfigureHub.ps1 Powershell script. See run additional installation scripts for more information.

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