"Unable to perform upload" error when uploading a template

Problem

When trying to upload a template from HotDocs Developer to HotDocs Hub, you receive a "Unable to perform upload" error message.  

Cause

This issue is typically caused by the upload session timing out when trying to upload a template larger than 15 megabytes.

Solution

You can resolve this problem by changing the session timeout settings in the HotDocsTemplateHubApi application.

To change the session timeout settings in HotDocsTemplateHubApi

  1. Open Internet Information Services (IIS) Manager.
  2. Navigate to the site containing the Hub applications.
  3. Right-click HotDocsTemplateHubApi.
  4. Select Explore; the HotDocsTemplateHubApi folder opens in Windows Explorer.
  5. Open the web.config file in a text editor.
  6. Add the following setting inside the system.web section of the web.config file:
    <sessionState timeout="20"></sessionState>
    For example:
    <configuration>
        ...
        <system.web>
             ...
             <sessionState timeout="20"></sessionState>
        </system.web>
    </configuration>
  7. Save your changes.

You should no longer get an error when uploading the template. You may need to increase the value of the timeout attribute if you still receive an error.

 

 

Table of Contents

Index

Glossary

-Search-

Back