"Something went wrong" error when loading Hub UI
Problem
When you try to load the Hub UI in your web browser, you receive a "Something went wrong" error instead of the login page.
Additionally, you see that:
- The HotDocs Hub UI application logs do not contain an error
- The Windows Event log contains the error message: "Exception message: Unable to get document from: https://xx.xx.xx.xx/HotDocsIdentityServer/core/.well-known/openid-configuration"
Cause
In the HotDocs Hub installation process, you need to copy the thumbprint of your signing certificate into the Hub DefaultConfig.psd1 script, removing any space characters it contains. This error is typically caused by leaving non-alphanumeric characters – such as spaces – in the signing certificate thumbprint.
Note: there may be an additional space character at the beginning of the thumbprint. You should check that this additional space is removed before adding the thumbprint to the DefaultConfig.psd1 script.
Solution
Follow the Hub installation steps again, ensuring that the thumbprint value used for the SigningCertificateThumbprint DefaultConfig.psd1 script setting does not contain any non-alphanumberic characters:
Installing Hub with User Management
- Installing HotDocs Hub with User Management – ensure that you check the value for SigningCertificateThumbprint in the post-installation script parameters.
Installing Hub with User Management and Active Directory
- Installing HotDocs Hub with User Management and Active Directory – ensure that you check the value for SigningCertificateThumbprint in the post-installation script parameters.