“An error occurred while handling your request” error on loading the Advance Authentication application

Problem

The HotDocs Advance authentication application displays a “An error occurred when handling your request” error message, after you are redirected from the Advance root or UI application. The authentication application should show the username/password fields, so you can log in to Advance.

Cause

This error is typically caused by missing initial user settings when first installing Advance or dbcreator settings missing from your SQL Server user.

Solution

Check that you configured an initial user. An initial user is required to log into the Advance root application after you first install Advance.

To configure the initial user:

  1. Open the HdaInstallerSettings.json file, located in your unzipped HotDocs Advance folder, in a text editor
  2. Check that you entered information for the following settings:
    • ApiSiteSettings.InitialUser.FirstName
    • ApiSiteSettings.InitialUser.LastName
    • ApiSiteSettings.InitialUser.EmailAddress
    • ApiSiteSettings.InitialUser.Password
  3. If the information is missing, enter information for those settings.
  4. Save your changes.
  5. Open the Windows Command Prompt.
  6. Change the directory to the unzipped HotDocs Advance installer folder.
  7. Change the directory to the bin folder.
  8. Run the installer with the following command:
    HdaInstaller install

The installer will update the settings of your Advance deployment to include the initial user settings. Check that you provided dbcreator permissions to your SQL Server user. The user under which you connect to SQL Server must have permission to create the Advance databases.

To give this permission to the user:

  1. Open SQL Server Management Studio.
  2. Connect to the instance of SQL Server used by Advance.
  3. In the Object Explorer pane, expand the top-level server node
  4. Navigate to Security Logins.
  5. Right-click the user with which Advance connects to SQL Server; this user is set in the database connection strings section of the HdaInstallerSettings.json file.
  6. Select the Properties option from the drop-down menu.
  7. Navigate to the Server Roles section of the Login Properties dialog.
  8. Check that the dbcreator server role is selected; if it is not, select the option.
  9. Click OK.

In your web browser, reload the Advance application to which you were trying to connect. The login screen now displays correctly.