"The URL does not match your current access token permissions" Error on Logging into Advance

Problem

When opening the HotDocs Advance root application in your web browser, you receive a "An error occurred while handling your request" error message.  When you look in the HdaAuth log file, you see a “The URL does not match your current access token permissions” error message.

Cause

This error is typically caused when the Domain and URL settings for the Advance installer are not lowercase. For example, setting AppDomain to YourOrganization.com when it should be yourorganization.com.

Solution

To solve this issue, you will need to update your installation configuration settings file and re-run the Advance installer.

  1. Open Windows Explorer and navigate to your Advance installation files folder (i.e. the location where you unzipped the Advance installer zip file).
  2. Open the bin folder.
  3. Open the HdaInstallerSettings.json file in a text editor.
  4. Edit the Domain and URL settings options, ensuring that the domain in each setting is all lowercase.
  5. Save your changes.
  6. Open the Windows Command Prompt as an administrator.
  7. Navigate to the unzipped HotDocs Advance folder.
  8. Navigate to the bin.
  9. Type the following command:
    HdaInstaller install
  10. Press Enter; the installer checks the prerequisites for Advance and updates the Advance applications.

Try re-launching the Advance root application in your web browser. You will now be able to log in to the application.