"Unexpected Error" when loading the HotDocs Hub UI

Problem

When loading the HotDocsTemplateHubUi application in Internet Explorer or Chrome, you receive a  "There was an unexpected error" error message.

Cause

If the HotDocsIdentityServer application logs contain a "Unhandled exception System.InvalidOperationException: IDX10614: AsymmetricSecurityKey.GetSignatureFormater..." error, try solution 4 below. The error is likely to be an issue with reading the signing certificate's private key.

However, this error message may have several different causes. Try the steps in the Solution section below in order. You can also check the HotDocsTemplateHubUI log file for more information.

Solution

1. Check that the Hub SQL Server user is not required to change their password

  1. Open SQL Server Management Studio.
  2. Expand the node for the SQL server instance used by HotDocs Hub.
  3. Navigate to Security > Logins.
  4. Right-click the user account Hub uses to access the database server.
  5. Select Properties.
  6. De-select the following properties if they are selected:
    • User must change password at next login
  7. Click OK.

Try reloading the HotDocsTemplateHubUI homepage.

2. Check that Hub has the correct database access permissions

See HotDocs Hub did not create a database on first load for more information.

3. Check that the TenancyResolver permissions are correctly created

  1. Open the HotDocsTemplateHubUi log file.
  2. Check for the following error message:
    "This operation requires a connection to the 'master' database. Unable to create a connection to the 'master' database because the original database connection has been opened and credentials have been removed from the connection string. Supply an unopened connection."
  3. If the error message above appears in the log, you must:
    1. Delete the existing Hub databases in SQL Server.
    2. Re-run the HotDocs Hub post-installation scripts.

4. Check that the application pool has permissions to access the signing certificate's private key

The identity for the application pool under which the HotDocs Hub applications run must have permissions to the private key of the signing certificate. Check that you have assigned permissions for the signing certificate.

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